Fehler nach eintragen eines Arma3 Server

Der Shop wurde vorübergehend deaktiviert. Nach dem Umzug und der Neuanmeldung des Gewerbes wird der Shop wieder zur Verfügung stehen!
  • Wo dran Liegt das ich habe das nur wenn ich arma3 Server hinzufüge.

    • Error Type:

      wcf\system\exception\ErrorException

    • Error Message:

      A non-numeric value encountered

    • File:

      */lib/system/WCF.class.php (346)

    • Stack Trace:
      • #0 */lib/system/api/GameQ/Filters/Secondstohuman.php (110):
      • wcf\system\WCF::handleError(2, 'A non-numeric value encountered', '*/lib/system/api/GameQ/Filters/Secondstohuman.php', 110, [ result => , value => , key => ])
      • #1 */lib/system/api/GameQ/Filters/Secondstohuman.php (105):
      • GameQ\Filters\Secondstohuman->iterate([ 0 => , 1 => ])
      • #2 */lib/system/api/GameQ/Filters/Secondstohuman.php (85):
      • GameQ\Filters\Secondstohuman->iterate([ 48 items ])
      • #3 */lib/system/api/GameQ/GameQ.php (638):
      • GameQ\Filters\Secondstohuman->apply([ 48 items ], GameQ\Server)
      • #4 */lib/system/api/GameQ/GameQ.php (358):
      • GameQ\GameQ->doApplyFilters([ 48 items ], GameQ\Server)
      • #5 */lib/system/cache/builder/GameserverCacheBuilder.class.php (90):
      • GameQ\GameQ->process()
      • #6 */lib/system/cache/builder/GameserverCacheBuilder.class.php (69):
      • wcf\system\cache\builder\GameserverCacheBuilder->getServerData()
      • #7 */lib/system/cache/builder/AbstractCacheBuilder.class.php (38):
      • wcf\system\cache\builder\GameserverCacheBuilder->rebuild([ serverID => ])
      • #8 */lib/page/GameserverPage.class.php (68):
      • wcf\system\cache\builder\AbstractCacheBuilder->getData([ serverID => ])
      • #9 */lib/page/AbstractPage.class.php (113):
      • wcf\page\GameserverPage->readParameters()
      • #10 */lib/system/request/Request.class.php (83):
      • wcf\page\AbstractPage->__run()
      • #11 */lib/system/request/RequestHandler.class.php (96):
      • wcf\system\request\Request->execute()
      • #12 */index.php (9):
      • wcf\system\request\RequestHandler->handle('wcf')


  • Weil nicht jedes Protokoll auf Secondstohuman zugreift. Bei "Multi Theft Auto" dürfte der Fehler auch auftauchen. ;)


    Bitte poste mal den kompletten Inhalt folgender Datei: \lib\system\api\GameQ\Filters\Secondstohuman.php

  • Der Fehler ist behoben. Warum auch immer ist dieser nicht mit in der letzten Version von mir veröffentlicht worden.

    Werde das Update sofort fertig machen und dann zur Prüfung bei WoltLab einreichen.


    Danke für den Hinweis.

  • ViperAC

    Hat das Label Behoben hinzugefügt
  • ViperAC

    Hat das Label Fehler hinzugefügt
  • ViperAC

    Hat das Label 1.3.1 hinzugefügt
  • ViperAC

    Hat das Thema geschlossen